APLawrence.com -  Resources for Unix and Linux Systems, Bloggers and the self-employed

© July 2005 Anonymous

repair lp

Author: Anonymous
Date: Wed Jul 20 17:24:29 2005
Subject: repair lp

I admit it, I think I toasted the command lp somehow...

I get the
request id is Cardkey-410(or whichever number it is on)

Nothing is in the queue when checking with lpstat

I ran
/usr/lib/lponlcr > /dev/lp0

nothing came out on the printer.

Any other ideas for troubleshooting this problem?

Got something to add? Send me email.

(OLDER)    <- More Stuff -> (NEWER)    (NEWEST)   

Printer Friendly Version

-> printer troubleshooting


Inexpensive and informative Apple related e-books:

iOS 8: A Take Control Crash Course

iOS 10: A Take Control Crash Course

Take Control of the Mac Command Line with Terminal, Second Edition

Sierra: A Take Control Crash Course

Take Control of Automating Your Mac

More Articles by © Anonymous

Wed Jul 20 18:25:37 2005: 823   TonyLawrence

Why would you expect anything to come out on the printer with that command? You gave it no input.

If "date > /dev/lp0" doesn't work, you've screwed up the kernel or you have a hardware problem. Otherwise, see the printing section of the FAQ for troubleshooting.

Wed Jul 20 18:28:39 2005: 824   anonymous

I had expected something to come out from doing a search on the site here, that says run that command, to verify the port...

/usr/lib/lponlcr > /dev/lp0
Type some lines then press enter and then CTRL+D

Wed Jul 20 19:20:28 2005: 825   TonyLawrence

OK :-)

You didn't mention that you typed things.. :-)

Did that give you an error? If it did, it's your kernel. Did it hang? If so, it could be hardware. If it came back to a prompt but didn't print, make sure /dev/lp0 is a device file, and if it is, your printer is confused or you need to send it a ctrl-l etc..

Thu Jul 21 13:54:46 2005: 829   BigDumbDinosaur

/usr/lib/lponlcr > /dev/lp0

It could be that the "real" /dev/lp0 somehow got deleted and that when he ran /usr/lib/lponlcr > /dev/lp0 the first time it created a regular file named lp0 in /dev. Assuming this is OSR5, he should be able to run mkdev parallel and straighten out the mess. Be sure to delete /dev/lp0 if it is not a character special file.

Thu Jul 21 15:46:14 2005: 834   anonymous

Ok, well I am leaning toward the 'lp' subsystem.
I ran makedev parallel and recreated the lp0 and relinked the kernel and then rebooted.
I typed and hit enter, and then ctrl+d and no errors, no hanging... nothing out on the printer.

I know you fellows feel it may be the kernel, if that is it, is there a way to rebuild it, so that it would go through re-detecting (right word?) the lp0 port?

Also, I went into "software manager" and re-verified the sytem software (full scan) to make sure the lp software was good, it said it repaired the lp files in a few places.
still no change though in the printing.

BTW, really appreciate the input so far, and any future ones! It is one of the best sites I have used for a few years.

Thu Jul 21 18:04:48 2005: 837   TonyLawrence

If it's not hanging, and /dev/lp0 is a character device, it's not likely that it's the kernel. More likely the hardware is bad somewhere.

Fri Jul 22 14:38:08 2005: 850   BigDumbDinosaur

Are you sure the kernel's notion of where to find the parallel port agrees with the actual hardware settings in CMOS? It could be that the kernel is talking to the standard parallel port I/O address at 0x378 but the actual port address set in CMOS is at 0x278 or (more rarely) 0x3BC. Also, does the interrupt being used by the kernel agree with that set for the port (typically IRQ 7 for the first parallel port)? If the CMOS settings full agree with the kernel's configuration (you can see what the kernel is thinking shortly after boot time) then, as Tony said, you probably have defective hardware.


Printer Friendly Version

Have you tried Searching this site?

This is a Unix/Linux resource website. It contains technical articles about Unix, Linux and general computing related subjects, opinion, news, help files, how-to's, tutorials and more.

Contact us

Printer Friendly Version

I've noticed lately that the paranoid fear of computers becoming intelligent and taking over the world has almost entirely disappeared from the common culture. Near as I can tell, this coincides with the release of MS-DOS. (Larry DeLuca)

Linux posts

Troubleshooting posts

This post tagged:




Unix/Linux Consultants

Skills Tests

Unix/Linux Book Reviews

My Unix/Linux Troubleshooting Book

This site runs on Linode

SCO Unix Sales, Support, & Service

Phone:  707-SCO-UNIX (707-726-8649Toll Free: 833-SCO-UNIX (833-726-8649)